# 文本对象

文本对象用于将信息添加至文档，诸如标签等。它们可以随处移动或放置在工作表区域的任何位置，甚至可以放置到由其他工作表对象覆盖的区域。

右键单击文本对象将显示文本对象：对象菜单。当文本对象为活动对象时，其还可从对象菜单存取。

## 对象菜单

右键单击该对象可打开文本对象对象菜单。此菜单命名包括：

* 属性...：打开文本对象属性对话框，您可在其中设置许多参数。
* 注： 允许创建和共享当前对象的注释。
* 顺序：此级联菜单仅当激活视图菜单中的设计网格命令时，或者当选中 总是显示设计菜单项目（在用户首选项：设计下）。它包含四个命令，用于设置工作表对象的布局层。有效的层数值范围为 -128 到 127。
  * 置于顶层：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最大值。
  * 置于底层：将工作表对象的布局层设置为当前工作表上任何工作表对象目前所使用的最小值。
  * 上移一层：以 1 为增量增加工作表对象的布局层。最大值为 127。
  * 下移一层：以 1 为减量减少工作表对象的布局层。最小值为 -128。
* 打印...： 打开打印对话框，可在其中指定打印设置。
* 以 PDF 打印...： 打开打印对话框，其中已预先选定 Microsoft Print to PDF 打印机。在按打印按钮后，程序会提示您输入 PDF 输出文件的名称。此命令仅可在系统上 PDF 打印机可用时可用。
* 发送到 Excel...：将文本导出到 Microsoft Excel。如果 Excel 还未运行,将会自动开启。文本就爱你过显示在新 Excel 工作薄中的单个单元格内。计算机上必须安装 Microsoft Excel 2007 或更高版本，此功能才可用。
* 复制到剪贴板：此层叠菜单包含用于工作表对象的各种复制选项。
  * 文本：将显示在文本对象中的文本复制到剪贴板。
  * 图片：将工作表对象的图片复制到剪贴板。图像将包括或不包括工作表对象标题和边框，具体取决于用户首选项：导出页面中的设置。
  * 对象：复制整个工作表对象到剪贴板，以便将它粘贴到布局中的其他地方或 QlikView 当前实例中打开的另一文档中。
* 链接对象： 对链接对象打开带有以下命令的菜单。 调整链接对象的位置：全部工作表中的全部链接对象都被调整到与高亮对象相同的位置和尺寸。   
  断开此对象/断开对象：这将破坏对象之间的链接，使它们成为具有不同对象 ID 的不同对象。
* 最小化： 图标化对象。单击对象标题（若显示）中的 the Minimize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最小化时，此命令才可用。
* 最大化： 放大对象以填充工作表。单击对象标题（若显示）中的 the Maximize icon 图标可产生相同的效果。仅当在标题页面上的对象的属性对话框中允许最大化时，此命令才可用。
* 还原： 将最小化或最大化的对象恢复到之前的大小和位置。双击最小化对象的图标或单击最大化对象的对象标题（若显示）中的图标 the Restore icon 将产生相同的结果。此命令仅适用于最小化或最大化的对象。
* 帮助： 打开 QlikView 帮助。
* 移除： 从工作表移除工作表对象。

## 一般

文本对象属性：一般页面通过右键单击文本对象并在浮动菜单中选择 属性命令打开，或者当一个文本对象活动时选择对象菜单中的属性打开。在此处可以进行文本，其背景及对齐等的设置。

* 前景：在此处您可以指定文本对象的前景。前景通常包括文本本身，但它也可以是一个图片。
  * 文本这是您输入要显示的文本的地方。该文本可定义为动态更新的计算公式。

    [用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  * 呈现形式文本对象中的文本可解释为至一个存储器或光碟中的一个索引。当选择文本时，文本对象的内容将总是解释并显示为文本。当您选择了图片时，QlikView 将尝试将文本内容解释为至一个图片的参考。该参考可能是磁盘上图片文件的路径（例如，C:\Mypic.jpg）或在 qvw 文档内部（例如，qmem:// &lt;Name&gt;/&lt;Peter&gt;）。QlikView它也可是一个链接到一个包含图片信息（如 =info(MyField）)的信息函数。如果 QlikView 无法将文本内容解释为至一个图片的有效参考，将会显示文本本身。

  * 图片丢失时隐藏文本：如果选择了该选项，并且由于某些原因不能翻译成为图片参考的说明，则 QlikView 将不会在文本对象中显示文本。文本对象将会留空。

  * 水平滚动条：如果勾选了此复选框，当文本内容太多无法在给定的区域完整显示时，一个水平滚动条将会被添加至文本对象中。

  * 垂直滚动条：如果勾选了此复选框，当文本内容太多无法在给定的区域完整显示时，一个垂直滚动条将会被添加至文本对象中。
* 布局：在该组中，您可以定义 QlikView 应如何在文本对象区显示文本或前景图片。
  * [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Text%20Object.htm)[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Text%20Object.htm)水平对齐：文本可在文本对象中水平左侧对齐，居中或右侧对齐。
  * 垂直对齐：文本可在文本对象中垂直顶部对齐、居中或底部对齐。
  * [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Text%20Object.htm)[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Text%20Object.htm)图片拉伸：该设置描述 QlikView 如何格式化前景图片，以使之适合放入文本对象区域。有四种替代方案。
  * 没有拉伸：如果选定该选项，图片将以原样显示，不作任何伸展。这可能会导致部分图片无法显示或仅填充部分的文本对象。
  * 填充：如果选定此选项，图片将会被拉伸至适合文本对象区，而不必担心图片显示比例的事。
  * 保持长宽比：如果选定此选项，图片将会尽量拉伸，以适合文本对象区，同时保持显示比例。这通常导致产生区域，要么在两侧，要么在图片未填充的上部和下部。
  * 以固定长宽比填充：如果选定此选项，图片将向两个方向拉伸，以填充文本对象区，同时保持显示比例。这通常导致图片在某个方向上的多余部分被裁剪。
  * 文本边框：此设置使您可以在文本对象的外边界和文本本身之间创建一个边框。边框的宽度可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。
* 背景：在背景组中您可以指定文本对象的背景。当前设置在预览空格中的右侧显示。
  * 颜色：如您希望在颜色背景中显示文本，请选择此遥控按钮。单击此按钮可打开颜色区域对话框，在当中可将颜色定义为纯色或渐变色。
  * 图片：如果您想将一个图片显示为背景，请选择此遥控按钮。要更改当前图片，请单击更改按钮。如果未在文本字段中输入文本，文本对象可用于将一个布局中的固定图片显示为工作表对象。支持的图片类型包括 jpg，png，bmp，gif 和动画形式的 gif。
  * 透明度：设置文本对象背景的透明度。设置为 100% 时，背景将完全透明。不论颜色或图片是否用于背景，透明度均适用。
  * 图片拉伸：该设置描述 QlikView 如何格式化背景图片，以使之适合放入文本对象区域。有关不同选项的详细情况，请参见以上的图片拉伸部分。
  * 对齐：背景可水平或垂直对齐。
* 备用状态： 在下拉菜单中选择一个可用的状态。以下备用状态始终可用。 继承：工作表和工作表对象通常处于继承状态，除非它们被 QlikView 开发者所覆盖。此设置继承自上述级别的对象，如果选中继承，则工作表中的图表可获得与工作表相同的设置。 默认状态：这是 QlikView 最常用的状态，它由 $ 表示。QlikView 文档通常处于默认状态。
* 对象 ID：这用于宏目的。每个工作表对象均会分配一个唯一 ID。我们建议您在 ID 中只使用字母数字字符。 对于文本对象，ID 以 TX01 开头。 链接对象共享相同的对象 ID。您可以稍后编辑此 ID 号。
* 打印设置...：按下此按钮可以打开打印设置对话框，并在其中定义页边距和页眉/页脚。

## 操作

在操作标签中，可指定单击对象时应执行的具体操作。此页面与按钮对象的操作页面完全相同。

## 了解详情

* [操作](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Actions.htm)

## “字体”

在此可设置要使用字体的字体，字形和大小。

可以设置任何单个对象的字体（对象属性：字体），或者设置文档中的全部对象的字体（应用到对象，在文档属性：字体中）。

此外，新对象的默认文档字体可以在文档属性：字体中设置。有两种默认字体：

1. 第一种默认字体（列表框，图表等）可用于大多数对象，包括列表框和图表。
2. 第二种默认字体（文本对象和按钮）可用于按钮和文本框，这两种对象通常需要更大的字体。

最后，新文档的默认字体可以在用户首选项：字体中设置。

对于图表，按钮和文本对象（搜索对象除外），还可以指定字体颜色。颜色可以是固定颜色，也可以是从表达式动态计算的值。此表达式必须是一个有效的颜色呈现形式，通过颜色函数创建。如果表达式的结果并非一个有效的颜色呈现形式，则将会使用黑色作为默认字体颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

其他的设置有：

* 投影：如果勾选此选项，将添加投影到文本。
* 下划线：如果勾选此选项，将添加下划线到文本。

所选字体样本显示在预览窗格中。

## “布局”

如果布局设置在对象属性页面完成，则布局设置仅应用于当前的对象。   
如果布局设置在文档属性页面完成，则布局设置将应用于文档中指定类型的全部对象。

### 使用边框

启用此项设置，可以在工作表对象周围使用边框。在下拉式菜单中选择以指定边框类型。

* 阴影强度：阴影强度下拉菜单可用于设定环绕工作表对象的阴影强度。同时还存在无阴影选择。
* 边框样式：以下预定义的边框样式可用：
  * 实线：实线纯色边框。
  * 凹陷：边框给人以在背景上陷压工作表对象的印象。
  * 凸起：边框给人以在背景上凸起工作表对象的印象。
  * 墙壁：边框给人以墙壁围绕工作表对象的印象。
* 边框宽度：此选项适用于所有边框类型。宽度可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。
* 颜色：点击此按钮，打开一个对话框，您可在其中从颜色调色板为所有边框类型选择适当的基本颜色。
* 彩虹：为所有边框类型创建彩虹边框。彩虹从工作表对象顶部的选中基本颜色开始。

如果所选择的样式模式为简单（位于文档属性：常规中），则不存在任何边框类型选择，仅有阴影强度下拉菜单和边框宽度设置。

### 圆角

在圆角组中，可以定义工作表对象的一般形状。这些设置允许通过超椭圆形从完美圆形/椭圆形到矩形绘制工作表对象：圆角仅在以下情况中可用：选择了高级样式模式（位于文档属性：常规下指定的默认设置）之间进行选择。

* 圆角：勾选此选项，使您可以选择圆角形状的替代项。
* 角：对应复选框保存未勾选的脚会绘制成矩形。
* 方形：2 - 100 的变量数，其中 100 定义为带完美方角的矩形，2 相当于完美椭圆形（圆形为 1:1 纵横比）。2-5 之间的方形通常是实现圆角的最佳数值范围。
* 圆角半径：此项设置可确定固定距离 (固定) 的圆角半径，或者以总计象限百分比表示 (相对 (%))的圆角半径。此项设置可允许您控制方形下基本的一般形状设置对角的影响程度。距离可以用毫米，厘米，英寸（"，inch），像素（px，pxl，pixel），点（pt，pts，point）或 docunits（du，docunit）表示。

### 层

在层组中，可将对象定义为常驻三层之中的一层：

* 底部：带有底部层属性的工作表对象绝对不会掩盖常规和顶部层中的工作表对象。它仅可以放置在底部层内其他工作表对象的顶部。
* 常规：一旦创建，工作表对象会常驻在常规（中间）层。常规层的工作表对象绝对不会被底部层的工作表对象掩盖，也绝对不会掩盖顶部层的工作表对象。
* 顶部：顶部层的工作表对象绝对不会被常规和顶部层的工作表对象掩盖。仅顶部层的其他工作表对象可以放置在顶部层的顶部。
* 自定义：顶部，常规和底部层分别相当于内部编号的 1，0 和 -1 层。实际上，可以接受 -128 - 127 之间的所有值。选择此选项，输入您选择的值。

### 主题制作工具...

打开主题制作工具向导，您可以在其中创建布局主题。

### 应用主题...

您可以将布局主题应用到对象、工作表或文档。

[布局主题](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Layout_Themes.htm)

### 显示

您可以在在显示组中指定工作表对象的显示条件：

* 始终：总是显示工作表对象。

* 有条件：工作表对象的显示或隐藏将取决于条件函数。系统将视条件（例如选择情况等）对条件表达式进行持续评估。仅当条件返回 FALSE 值时工作表对象才会隐藏。

  [条件函数](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ConditionalFunctions/conditional-functions.htm)

信息注释

对文档有 Admin 访问权限的用户可覆盖所有显示条件，方法为选择显示所有工作表和对象（位于文档属性：安全性中）。此项功能可通过按 Ctrl+Shift+S 组合键进行切换。

[文档属性：安全性](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Document_Properties_Security.htm)

### 选项

在选项组中，您可以禁止移动和调整工作表对象大小。本组中的此项设置仅在以下情况下相关：在文档属性：布局和工作表属性：安全性中启用了相应复选框。

* 允许移动/调整大小：如果取消选择此选项，则将无法移动工作表对象或调整其大小。
* 允许复制/备份：如果取消选择此选项，则将无法复制工作表对象。
* 允许信息：使用 info 函数时，每当字段值具有与之相关的信息时，窗口标题中都将显示一个信息图标。如果您不想信息图标显示在标题中，可以取消勾选此选项。  
    
  [Info](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Scripting/ScriptPrefixes/Info.htm)
* 根据数据调整大小：通常，当选择引起表格的大小小于工作表对象分配的大小时，QlikView 中全部数据表的工作表对象的边框将会缩小。通过取消选中该复选框，将会关闭大小的自动调整，任何剩余空间都将留空。

### 滚动条

更改滚动条布局的各种控件位于滚动条组中：

* 保留滚动条的位置：启用此设置，在另外一个对象中做出选择时，QlikView 将偿试用一个滚动条保留表格和图表的滚动条位置。此项设置也必须在用户首选项：对象中启用。关闭文档时，滚动位置不会保留。
* 滚动按钮：设置滚动按钮颜色。点击此按钮，设置颜色。注意，中等灰度往往会令滚动栏呈现出最佳结果。单击适当按钮，打开颜色区域对话框，您可在其中将颜色定义为纯色或渐进颜色。
* 滚动背景：设置滚动条背景颜色。点击此按钮，选择颜色。
* 滚动条宽度：此控件同时影响滚动条符号的宽度和相对大小。
* 滚动类型：设置滚动栏的样式。在下拉控件中选择一个样式。经典滚动条样式相当于 QlikView 4/5 滚动条。标准滚动栏样式拥有更现代的外观。第三个样式是浅色，即滚动栏拥有更细，颜色更浅的外观。  
  必须将样式模式设置为高级以使滚动条样式可见。通过打开设置下拉菜单并选择文档属性，可在一般标签中找到此设置。

* 应用于...：打开标题和边框属性对话框，您可在其中设置 布局页面设置的属性的应用位置。

## “标题”

如果标题栏设置在对象属性页面完成，则设置仅应用于当前的对象。   
如果标题栏设置在文档属性页面完成，则设置将应用于文档中指定类型的全部对象。

在标题页面上，您可以指定完全不同于一般对象布局的布局选项。

* 显示标题：勾选了此选项时，标题将会被移至工作表对象的顶部。列表框和其他“框对象”将默认开启该选项，而按钮，文本对象和直线/箭头对象则不会默认开启。
* 标题文本：在文本框中，您可以输入标题，以便显示在工作表对象的标题中。使用字体…按钮更改标题字体。

设置不同状态下的标题色彩。活动颜色和非活动颜色的设置彼此分开来。

点击背景颜色或文本颜色按钮，打开颜色区域对话框。背景颜色可在色彩区域 对话框上被定义为纯色或 渐变色。文本颜色可使用颜色函数定义为固定或计算颜色。

[颜色函数](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/ChartFunctions/ColorFunctions/color-functions-charts.htm)

* 文本换行：如果勾选此选项，则标题将显示两行或多行。
* 标题高度（行数）：在此编辑框内设置标题行数。

可对常规或最小化 QlikView 工作表对象设置大小/位置来精确确定和调整 QlikView 对象的大小和位置。这些设置采用像素度量：

* X 位置：设置工作表对象左侧相对于工作表左缘的水平位置。
* Y 位置：设置工作表对象顶部相对于工作表上缘的垂直位置。
* 宽度：设置 QlikView 工作表对象的宽度。
* 高度：设置 QlikView 工作表对象的高度。

可使用对齐标题选项更改标题标签的方向：

* 水平：可以水平对齐标签：在标题区域内左对齐，居中或右对齐。
* 垂直：可以垂直对齐标签：在标题区域内顶部对齐，中线对齐或底部对齐。

特殊图标   
许多工作表对象的对象菜单命令均可配置为标题图标。勾选列表内每个命令左边的复选框即可选择用于显示标题图标的命令。

信息注释慎用特殊标题图标。图标太多只会令用户感到困惑。

* 允许最小化：选中此选项时，如果对象可以最小化，将会在工作表对象的窗口标题中显示最小化图标。此外，还可以通过双击该标题最小化对象。

* 自动最小化：在勾选允许最小化时适用该选项。在相同的工作表上为若干工作表对象勾选自动最小化时，除去一项以外，其他全部对象在任何时候都会自动最小化。此选项十分有用，例如可以交替显示相同工作表区域中的若干图表。

* 允许最大化：勾选了此选项时，如果对象可以最大化，则将会在工作表对象的窗口标题中显示最大化图标。此外，还可以通过双击标题最大化对象。如果同时勾选了允许最小化和允许最大化，双击标题将会导致对象最小化。

* 帮助信息：您可以在此处输入帮助文本。该信息将会显示在弹出窗口中。帮助文本可以作为计算公式指定。此选项不适用于文档一级。单击 ... 按钮打开编辑表达式对话框，以更方便编辑长公式。

    
  [用于计算公式的表达式语法](https://help.qlik.com/zh-CN/qlikview/September2026/Subsystems/Client/Content/QV_QlikView/Expression_syntax_for_calculated_formulas.htm)

  例如，您可以输入工作表对象的说明。这将会添加一个帮助图标到对象的窗口标题中。当鼠标指针移到图标上时，该文本将会显示在弹出窗口中。